Boost logo

Boost :

From: Tobias Schwinger (tschwinger_at_[hidden])
Date: 2005-06-30 11:22:48

John Maddock wrote:
>>That use of free_or_static seems just plain wrong. Why would you
>>synthesize a type while giving a choice as to how it is
>>decorated? Yes, you can document that free_or_static and
>>undecorated are the same in this context, but it is confusing at
> Since free functions and static [member] functions are the same type, should
> we just use "free_" as the prefix and drop "free_or_static_" ?

To be precised, it isn't a prefix but a "full grown" identifier of an aspect tag ;-).

Initially it was called "unbound". It was changed to "free_or_static" because it
is more intuitive. But that "_or_" may cause confusion.

So reverting to "unbound" would be another option...

> I've no strong preference over this suggestion, just looking to avoid any
> confusion,

Yeah, me not either. Comments welcome!



Boost list run by bdawes at, gregod at, cpdaniel at, john at