Boost logo

Boost :

From: Tobias Schwinger (tschwinger_at_[hidden])
Date: 2005-06-30 14:48:57

Rob Stewart wrote:
> From: Tobias Schwinger <tschwinger_at_[hidden]>
>>John Maddock wrote:
>>>Since free functions and static [member] functions are the same type, should
>>>we just use "free_" as the prefix and drop "free_or_static_" ?
>>Initially it was called "unbound". It was changed to "free_or_static" because it
>>is more intuitive. But that "_or_" may cause confusion.
>>So reverting to "unbound" would be another option...
> In contradiction to my statement in another branch of this thread
> about not having multiple tags that are interchangeable, perhaps
> having both "free" and "static" would be helpful.

And require another underscore suffix for static...

Boost list run by bdawes at, gregod at, cpdaniel at, john at