Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-07-08 11:46:43


From: Thorsten Ottosen <nesotto_at_[hidden]>
> Jonathan Turkanis <technews <at> kangaroologic.com> writes:
>
> > sure that the analogy with the iterators library will be very effective in
> > helping users understand these templates. As a result, I'm think of using the
> > less technical-sounding names "generic_streambuf" and "generic_stream."
> >
> > What do people think?
>
> seems ok. have you considered

Hmmm. I agree that the original names are misleading. They
don't create a facade over another class, they are provide the
functionality directly. However, "generic_streambuf" sounds too,
well, generic.

> basic_streambuf<>
> basic_stream<>
>
> as an analogy with regex/string etc ?

As compared to std::basic_istream et al, these classes are hardly
what one would call basic. They push the concepts far forward.
Thus, should these classes be standardized, std::basic_stream
doesn't stand apart from the other class templates. Furthermore,
they aren't specialized on the character type as those other
templates are, so they deserve different names.

Is there are reason not to call them simply "stream" and
"streambuf?" If you're concerned about the possibility of
typedefs or other uses of those names in either the std or boost
namespace, then how about "policy_stream" and "policy_streambuf?"

> > I'm thinking of renaming the headers that are curently based on component
> names
> > so that all headers will have short, simple names. E.g.,
> >
> > bzip2.hpp
> > counter.hpp
> > gzip.hpp
> > line.hpp
> > newline.hpp
> > one_step.hpp
> > regex.hpp
> > stdio.hpp
> > symmetric.hpp
> > test.hpp
> > zlib.hpp
> >
> > Thoughts?
>
> I like you renaming.

Seems reasonable given that they are already in the filter
subdirectory.

-- 
Rob Stewart                           stewart_at_[hidden]
Software Engineer                     http://www.sig.com
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk