Boost logo

Boost :

From: Allen (yaozhen_at_[hidden])
Date: 2005-07-10 06:34:27

Though there may be many details about this, I think the suggestion will
be really helpful in improving the readability of the Boost code.

Most readers/users of Boost are not familiar with specific compiler
versioning details, and with these macros defined and used consistently,
  It will be extremely easy for readers to recognize those
compiler-specific workaround parts in the code, and choose to look into
or just ignore them.

I also suggest that these macros be a part of the Boost.Config, and all
the Boost library authors to utilize them consistently. Furthermore, all
the existing code could be rewrite accordingly if possible.

Edward Diener wrote:
> I think this suggestion would make for a little more readable code in
> its own small way.

Boost list run by bdawes at, gregod at, cpdaniel at, john at