Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-07-10 09:22:57

Eelis van der Weegen <gmane_at_[hidden]> writes:

> So, in conclusion, the motivation for your dual_state is very valid, but
> personally I think Boost.Optional is a more appropriate design.

IMO the "guaranteed object delivery" feature makes for a useful
specialization of the Boost.Optional design. However, it would be
nice to have both; it's not an alternative to Boost.Optional.

There's a lot of resonance with the Boost.Parameter library in here.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at