From: David Abrahams (dave_at_[hidden])
Date: 2005-07-11 08:05:32
Edward Diener <eddielee_at_[hidden]> writes:
>> Maybe that wasn't the best choice of words. I just meant that we'd
>> lose the functionality provided by BOOST_WORKAROUND if we started
>> using the macros you suggest instead.
> We would not so much as lose the functionality as offer a more
> simplistic and readable way to express it. My suggestion is just about
> readability. When I see:
> #if BOOST_WORKAROUND(nnnn,comparison operator)
> I often can not tell to what it refers without some comment. But if I
> saw, as an example:
> #if BOOST_COMPILER_VC71
> it becomes easier to understand.
You obviously didn't read the entire comment in workaround.hpp then.
#if BOOST_COMPILER_VC71 can't support
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk