From: Darren Cook (darren_at_[hidden])
Date: 2005-08-01 20:46:28
>>> namespace: boost::multivalues
>>> base class: multivalue
>>> all_of: all_values
>>> any_of: any_value
>>> none_of: no_values
>>> one_of: one_value
> I'm hoping someone else will jump in soon enough with other
> suggestions since the release furor is mostly past now.
I thought this naming was okay. Also "junctions" is acceptable, if they
behave similarly enough to the perl implementation.
>>junctions (multivalues) are trivial, but i must admit they aren't.
Yes, I've been following the thread and the non-obvious things you've
come across is interesting. I've had nothing useful to add yet. I think
when in doubt doing the same as the perl implementation may be best.