Boost logo

Boost :

From: Matthew Vogt (mattvogt_at_[hidden])
Date: 2005-08-08 15:33:55

Rob Stewart wrote:
> Would "some_of" be a better name than "n_m_of?" The latter isn't
> the most inventive name and I was hoping to find something better
> (if there is anything). Both would be parameterized with two
> values (min and max). I know "some" is quite vague, like "any,"
> but the required parameters would force supplying the minimum and
> maximum.
> We could also try "min_max_of," but that suggests a function that
> returns a pair of values.
> "n_m_of" uses anti-alphabetical ordering of the letters. That
> rather suggests the template argument order of maximum then
> minimum. Perhaps changing to "x_y_of" or "a_z_of" would be
> better?

How about 'subrange_of'?

'subset_of' would sound better, but 'subrange' indicates that the desired subset
would be min/max bounded.


Boost list run by bdawes at, gregod at, cpdaniel at, john at