Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-08-14 19:42:12

Rogier van Dalen <rogiervd_at_[hidden]> writes:

>>>namespace unicode {
>>> struct range {
>>> enum type {
>>> latin1_supplement,
>>> latin_extended_a,
>>> latin_extended_a,
>>> ipa_extensions,
>>> // ...
>>> }
>>> };
>> Yes - it should be namespaced - I had omitted it for clarity.
>> I still think that the uni prefix might be useful to remind those
>> programmers using 'using unicode' that these are Unicode functions - but
>> I am happy to lose that argument.

>> Oops - caught - I was attempting to write it in such a way that it could
>> be used from C as well as C++ - hence BOOL not bool.
>> DWORD is actually uint32_t.
> I know, but - correct me if I'm wrong - I think the sort keys consist
> of 16-bit integers.

Rogier and Graham,

Please try to leave a space between the text you quote and your reply,
so that your very important discussion has the impact it deserves.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at