Boost logo

Boost :

From: Matt Calabrese (rivorus_at_[hidden])
Date: 2005-09-01 02:26:10

On 8/31/05, Aleksey Gurtovoy <agurtovoy_at_[hidden]> wrote:

> I agree that 'mapped_type' would be a better name here, but then I
> find the whole '_type' convention for these two suboptimal:
> 1. It makes it sound like the templates are trivial metafuntions for
> the corresponding STL typedefs, which is not the case.
> 2. Pretty much everything in MPL is a type; the '_type' suffix doesn't
> add any semantic value to the names besides contributing to #1,
> and, I believe, is somewhat misleading: "What do you mean, key
> _type_? It's key's value!".
> So, if we were to rename/introduce synonyms for these, I'd rather keep
> 'key'/'value' terminology and replace '_type' with something more
> explicit/less ambiguous [key_part and value_part table]

Definately agreed on those points, though I still say it should be
mapped_part as opposed to value_part as it's the mapped part of the value
(again, to stay consistent with STL naming).

-Matt Calabrese

Boost list run by bdawes at, gregod at, cpdaniel at, john at