Boost logo

Boost :

From: Dave Gomboc (dave_at_[hidden])
Date: 2005-09-02 21:16:46

> o Are the names 'binary_int' and 'binary_nibble' good names?
> Pavel Vozenilek, who has very kindly been my Boost mentor,
> suggests 'bits' and 'nibble' may be better names.

"nibble" sounds like taking a small bite, and AFAIK, that's precisely why
it's called that! But in computing, bite is spelled byte, and similarly,
four binary bits make up a nybble (also using a 'y'). At least, AFAIK all
my computing magazines from 20 years ago (back when nybbles were less
unimportant :-) used this spelling; they were printed in the USA.



forwards to nibble, so I imagine that nibble must be common in some

On to your main question:

int refers to the acceptable range (short int <= int <= long int), so I
think binary_int isn't quite what we're looking for.

After trying out a few possibilities, I like the look of




Boost list run by bdawes at, gregod at, cpdaniel at, john at