Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-09-21 16:45:08

Brian Ravnsgaard Riis <brian_at_[hidden]> writes:

> Andrey Semashev wrote:
>> Brian Ravnsgaard Riis wrote:
>>>Rob Stewart wrote:
>> I agree the "guard" is better. But the variable type name is scope_guard,
>> many scope guard tools are resided in boost::guard namespace, the function
>> for creating guards is make_guard. Aren't there too much guards here?
> Yes, probably. As I said, just a thought...

I don't care how large the population of guards is, if "guard" is the
right name.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at