Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-09-22 14:39:42

From: Thore Karlsen <sid_at_[hidden]>
> I like "dismiss" for disabling, but I don't think "summon", "guard", or
> "post" intuitively make sense. "enable"/"disable" or

I think "guard" does make sense, but it overloads the other uses
of the word in the library which will make verbal discussions

> "activate"/"deactivate" sound better to my ears, unless there is a
> better word to pair with "dismiss". To be honest, I'm not convinced that
> too much focus on comparing this concept with a real-world guard is a
> good thing.

I think the object is aptly named and trying to find a suitable
pair of words that map to real world concepts is worthwhile.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at