Boost logo

Boost :

From: Jeff Flinn (TriumphSprint2000_at_[hidden])
Date: 2005-09-22 15:03:46

"Rob Stewart" <stewart_at_[hidden]> wrote in message
> A variation on "guard" (the verb) is "protect," which has the
> right meaning and avoids overloading the word "guard" to excess:
> scope_guard g;
> if (a) g.dismiss();

    if (a) g.ignore();

To me dismiss has much more heavy handed connotations.

> ...
> if (b) g.protect();
> "Secure" is another choice.

Either of these pair well.

Just a thought, has g.on() and been considered?


Boost list run by bdawes at, gregod at, cpdaniel at, john at