Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2005-09-29 07:43:25

On Thu, 29 Sep 2005 08:32:24 +0200, Robert Kawulak wrote
> > > Uhh, maybe you're right ;-) I don't know why, but it just
> > "byte my eyes"
> > > when I see a type named "something_value"... Nevermind, if
> > people here
> > > really resist that it should be called constrained_value instead of
> > > constrained_type, then OK - I'll change it.
> >
> > Why not just 'constrained'? ie. constrained<int>?
> Sounds good, and how to call the library? 'constrained_types'?

When I called it constrained_value I did that b/c the types that could be
create d with it are all value types. In retrospect, constrained_int might
have been more accurate for my class. For what you're working on, I think
constrained_type or just plain constrained would probably be fine too.


Boost list run by bdawes at, gregod at, cpdaniel at, john at