Boost logo

Boost :

From: Paul A Bristow (pbristow_at_[hidden])
Date: 2005-09-30 05:00:17

| -----Original Message-----
| From: boost-bounces_at_[hidden]
| [mailto:boost-bounces_at_[hidden]] On Behalf Of Robert Kawulak
| Sent: 29 September 2005 20:26
| To: boost_at_[hidden]
| Subject: Re: [boost] Bounded types (or maybe not 'bounded'
| anymore? ;-)
| > The library name should probably be "Constrained," the
| > namespace, "constraineds," and the type, "constrained," if you go
| > this route. (That's in keeping with Boost.Tuple, which uses the
| > "tuples" namespace and the "tuple" type.)
| >
| > If you call it the "Constrained Types" library, and use the
| > namespace "constrained_types," does "constrained" for the type
| > name fit with Boost prior art and intention? Those names sound a
| > lot better, so that may be sufficient justification, but I don't
| > want to presume this approach is acceptable to Boost as a whole.
| For me the latters also sound better, what do you people think?

I think these short, unabbreviated but accurate names sound good,
and fit with established names.

Also I am sure I am not alone in being encouraged by the progress so far -
but Boost needs this to be _FINISHED_ including the documentation (including
acknowledgement to the several previous but not quite finished
contributions, and rationale), tests and EXAMPLES of use. If this can be
achieved, it will be most valuable, and probably can be retrofitted in
several existing libraries.


Paul A Bristow
Prizet Farmhouse, Kendal, Cumbria UK LA8 8AB
+44 1539 561830 +44 7714 330204
mailto: pbristow_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at