Boost logo

Boost :

From: Rob Stewart (stewart_at_[hidden])
Date: 2005-10-07 13:51:26

From: "Peter Dimov" <pdimov_at_[hidden]>
> Rob Stewart wrote:
> > From: Caleb Epstein <caleb.epstein_at_[hidden]>
> >>
> >> Ergo I restate my case that this library should NOT be called Pimpl.
> >> Maybe PimplHolder or something like that, but calling it Pimpl
> >> confuses at least two people :-)
> >
> > I was never confused as to whether this library would magically
> > implement the impl class, though I think Asger may have flirted
> > with the idea of forwarding functions. Nevertheless, I can see
> > calling the class pimpl_ptr, if that suffix would clarify matters
> > for you.
> Let's not forget that the first P in pimpl stands for 'pointer'. :-)

I raised that point previously, but that didn't seem to help.

Rob Stewart                           stewart_at_[hidden]
Software Engineer           
Susquehanna International Group, LLP  using std::disclaimer;

Boost list run by bdawes at, gregod at, cpdaniel at, john at