From: David Abrahams (dave_at_[hidden])
Date: 2005-10-31 11:51:30
Cromwell Enage <sponage_at_[hidden]> writes:
> --- Daryle Walker wrote:
>> Is BOOST_MPL_MATH_RATIONAL_PART_OF_RATIONAL a
>> re-statement of the rational number itself?
>> Or is it supposed to be the remainder after taking
>> out the "whole" part?
>> If the latter, then the name should have
>> replacing the first "RATIONAL", since "fractional"
>> and not "rational" better describes a left-over bit.
> For consistency this part of the macro name is
> lexically the same as the template name whose
> specialization the macro creates, i.e. rational_part.
Both names seems misleading to me. What's wrong with
-- Dave Abrahams Boost Consulting www.boost-consulting.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk