Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2005-10-31 16:38:20

Cromwell Enage <sponage_at_[hidden]> writes:

> --- Andy Little wrote:
>> Shouldn't the two parts be described as integer_part
>> and fractional_part?
> IMHO integer_part is not as descriptive as whole_part.

whole_part sounds like an oxymoron, and will surely be confusing.

integer_part is common usage. It doesn't matter if you don't think
it's descriptive; everyone will understand it... unless of course you
mean something different from what everybody means by "integer part."

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at