Boost logo

Boost :

From: Simon Carter (simon.carter_at_[hidden])
Date: 2005-11-11 09:07:38

Alberto Ganesh Barbati <abarbati <at>> writes:

> Kevin Sopp wrote:
> >
> > Given a type T which is a model of MPL lambda expression, permute<T,
> Args1,


> What I would like
> to say is that you should choose a name different from "permute" because
> it is misleading....
> ....In other words "permute" conveys the concept
> that you already have a list of types and you provide a different
> re-ordering of such list (compare with std::next_permutation,
> std::last_permutation).

The word you are looking for is combination (combine)


Boost list run by bdawes at, gregod at, cpdaniel at, john at