|
Boost : |
From: Beman Dawes (bdawes_at_[hidden])
Date: 2006-02-07 12:29:16
"Martin" <adrianm_at_[hidden]> wrote in message
news:loom.20051228T091806-138_at_post.gmane.org...
> 4. A suggestion is to overload exists, is_directory etc for status flags
> ....
Status flags has morphed into a full-fledged file_status class, and, as you
suggested, exists, is_directory, etc. have been overloaded.
This makes user code much more readable and is much less error-prone, IMO.
Thanks for the suggestion!
> 3. The documentation doesn't say how other_flag is supposed to work.
The docs now say:
bool is_other(file_status s);
Returns: return exists(s) && !is_regular(s) && !is_directory(s) &&
!is_symlink(s)
> If an implementation adds more flags, will other_flag be set for these?
No. I'll update the docs to make that clear.
Thanks,
--Beman
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk