Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2006-02-19 17:16:43


David Abrahams wrote:
> "Peter Dimov" <pdimov_at_[hidden]> writes:
>
>> IPC > InterProcess, even for a library that is not just for
>> communications. It's a better name, not necessarily a better
>> description, just like Shmem is a better name than shared_memory.
>
> Shptr<T> x(new T)
>
> ?? ;-)

shared_pointer<T> x( new T );

? :-)

shared_ownership_pointer<T> x( new T );

?? :-))

Shptr<> is actually not that bad, but shared_ptr > Shptr because of the
scoped/auto/weak_ptr relatives.

> Seriously, why is "Shmem" better than "shared_memory?"

Because it's short and unique. You can still pronounce it "shared memory",
if you like.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk