Boost logo

Boost :

From: Ananda Tallur (anand_at_[hidden])
Date: 2006-03-07 04:39:30

Hello Gennadiy,

Thank you very much for you answer, and sorry for having forgotten
something a important as mentionning the Boost version used !

In fact, I have tried with three Boost versions : 1.33.1, 1.33.0, and
1.32.0, compiled with Apple gcc 4.0.1, and the same is exactly the
same with these three versions.

I have just tried the test again, with the included version of
unit_test_framework :
- including <boost/test/included/unit_test_framework.hpp> instead of
- not linking the test program against boost_unit_test static library

The test result is exactly the same as when using the static library
version :

Running 1 test case...a : 13691
boost_unit_test_gcc4_pb_sample.cpp(18): error in "  
SampleTest::sampleTest": check a == 12345 failed [13691 != 12345]
*** 1 failure detected in test suite "Sample test"
So it really seems to show that there is a problem with the compiler  
from Apple.
I am currently using build Apple gcc 4.0.1 build 5250, but I have  
also tried with previous version (build 5247), and the problem is the  
But it works with gcc 3.3 from Apple, and with gcc 4.0.1 without  
I have already issued a bug report to Apple.
Thank you again for your answer, do you think of some other test I  
could do to precise the problem ?
And also, it would be great if another Mac OS X user could try the  
test program I have sent in my previous e-mail, and confirm the problem.
Best regards,
On 6 mars 06, at 18:00, boost-request_at_[hidden] wrote:
> Date: Mon, 6 Mar 2006 11:44:43 -0500
> From: "Gennadiy Rozental" <gennadiy.rozental_at_[hidden]>
> Subject: Re: [boost] problem with boost_unit_test :
> 	BOOST_CLASS_TEST_CASE	seemsno the access instance at the right
> 	address, on Mac OS X,	with gcc 4.0.1/2 with optimization level > 0
> To: boost_at_[hidden]
> Message-ID: <duhotr$dmg$1_at_[hidden]>
> Hi, Ananda
> I did not reply to your post in users list, since I do not have any  
> idea
> what could be casuing this. One question: which version of boost  
> you are
> using. One recommendation: try to use included version of UTF
> <boost/test/included/unit_test_framework.hpp> and let us know the  
> results.
> Regards,
> Gennadiy

Boost list run by bdawes at, gregod at, cpdaniel at, john at