Boost logo

Boost :

From: Gennadiy Rozental (gennadiy.rozental_at_[hidden])
Date: 2006-03-09 10:45:48


"Jens Theisen" <jth01_at_[hidden]> wrote in message
news:9pLWNg6kciB_at_jens-theisen.de...
> Hello,
>
> what do people think about Boost.Range support?
>
> Instead of writing
>
>
> my_range_type r = <complex expression>;
>
> std::vector< int > v = list_of(1)(2)(3);
>
> BOOST_CHECK_EQUAL_COLLECTIONS(r.begin(), r.end(), v.begin(), v.end());
>
>
> one could write more conveniently the single line
>
>
> BOOST_CHECK_EQUAL_RANGES( <complex expression>, list_of(1)(2)(3) );
>
>
> It's also more readable and would so improve the documentational aspect of
> tests.

I think this idea has some merit. But I wouldn't want to enforce yet another
dependency on Boost.Test users. There are two options here:
 1. Put theses definition into separate header
 2. Guard these definitions with something like ifndef
BOOST_TEST_MINIMAL_DEPENDENCIES

In any case modification will have to be done after release.

Genandiy


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk