Boost logo

Boost :

From: Alexander Nasonov (alnsn_at_[hidden])
Date: 2006-04-05 02:59:22


Oleg Abrosimov <beholder <at> gorodok.net> writes:
> my vote is that the library should be accepted to boost

Thanks/Spasibo :)

> 1) in file promote_enum_test.cpp the version of compiler can be increased.
> [ text skiped ]
> this test is broken for
> Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 13.10.3077 for 80x86
> as well

Ok

> 2)
> I've modified the test function from promote_util.hpp :
> [ code skiped ]
> in order to suppress modifier applied to reference warning:
> "promote_util.hpp(26) : warning C4181: qualifier applied to reference
> type; ignored
> promote_basic_test.cpp(82) : see reference to function template
> instantiation 'void test<arr_ref,arr_ref>(void)'"

Will be applied.

> this test should be named test_cv, isn't it?

You're right.

> enough, but common usage examples would help.
> a) understand these components
> b) for users new in this domain it helps learn about the domain and
> about some common techniques and abilities.
> so, one can read docs and say: "Wow! I can use it my code! And that is
> _how_ I can do it!"

I understand your concern. As I pointed out in other reply, I can't do
this without permission of type_traits authors.

> It should contain references to standard paragraphs about "integral
> promotion" (4.5) and "floating point promotion" (4.6) to describe
> these terms. It is necessary, because the behavior of components
> can not be understood without understanding of terms.

I'll add the references.

> May be it makes sense to include full text of corresponding
> paragraphs of standard in documentation. (for FP it is just one line)

IMHO, that's too much.

> mistyping error
Noted.

> the line:
> // 4.5/3 (integral bit-field) is not supported.
>
> _must_ be reflected in docs. Along with rational. (even
> if it is a lack of resources)

It's implied because a bitfield can't be template argument.
I'll reflect it in the docs.

> All the non-standard types stuff in integral_promotion.hpp seems to be
> untested. And the purpose of this code is unclear.

I tried to cover promotions beyond the standard. It seems that different
compilers do this differently. It might even depend on flags (eg. -ansi
or -strict).
I'm going to play eith this more.

> same for test_platform_dependent test in file promote_util.hpp - it is
> not used at all.
Will be removed.

--
Alexander Nasonov

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk