Boost logo

Boost :

From: Darren Cook (darren_at_[hidden])
Date: 2006-05-09 21:29:27

> With regard to naming, I think fusion::pair is a bad name. Perhaps it
> should be instead named fusion::keyed? I think the name pair should be
> reserved for two values (std::pair) or two types (mpl::pair). The mixing
> of the two was unexpected.

Yes, I also thought that was a surprising use of the word pair.


Boost list run by bdawes at, gregod at, cpdaniel at, john at