From: Joel de Guzman (joel_at_[hidden])
Date: 2006-05-19 18:27:12
Tobias Schwinger wrote:
> Here's an implementation.
> I changed the name from 'result' to 'lambda' (because nested classes
> have the same name as the enclosing ones).
> o lambda.hpp MPL-lambda adapter for result computation
> o lambda_test.cpp test/example for MPL-lambda adapter
> TESTED WITH:
> o GCC 3.4.2
> o MSVC 8.0
> o MSVC 7.1
> It works really well -- the technique also reduces ambiguity problems
> caused by ADL with mutliple namespaces!
> Hope you like it as much as I do...
Tobias, this looks really delicious! I'd love to see more of it!
-- Joel de Guzman http://www.boost-consulting.com http://spirit.sf.net
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk