Boost logo

Boost :

From: Oleg Abrosimov (beholder_at_[hidden])
Date: 2006-06-15 03:33:40

Janek Kozicki writes:
> Given that, maybe there is no need at all to define velocity.hpp,
> pressure.hpp and all the others with dimensions combined? When the user
> plans to work with velocity he will just write:
> // requires only this macro
> BOOST_UNITS_DIVIDED(pqs::length::m,pqs::time::s,velocity);
> instead of this:
> // requires file velocity.hpp with dozens of definitions inside
> typedef pqs::velocity::m_div_s velocity;

or, may be as simple as pqs::velocity?

> And now it's the user who makes a choice whether to use name "velocity"
> or name "m_div_s" or name "m_per_s". And all arguments 'div' versus
> 'per' become obsolete :)
> PS: sorry about scattering this single topic into to posts on the mailing list :/

Boost list run by bdawes at, gregod at, cpdaniel at, john at