Boost logo

Boost :

From: Pavol Droba (droba_at_[hidden])
Date: 2006-07-02 17:52:55

Well, it depends on what you define as 'de-facto' standard.
I think that both names are equaly good.

A quick 2-minute search gives me few example in favor of trim_left:
- Microsoft - All libraries provieded by microsoft MFC, ATL, .Net, use
  *Left versions
- Symbian API - has TrimLeft

- Probably not very serious, but simple google comparison give following
"trimhead OR trimhead" : 1,510 results
"trim_left OR trimleft" : 40,400 results

I don't have much time to look elsewhere, feel free to supply

Before considering your proposal, I would really need to see
better argument then your personal opinion, since changing a name
of a function that is already in use for some time is quite serious


Yuval Ronen wrote:
> After reading Jeff's post about super_string, it suddenly hit me: on RTL
> languages, the head of the string is actually the right side, so
> trim_left/trim_right should really be trim_head/trim_tail... I know that
> the left/right names for trimming are de-facto standard. In fact, they
> are so rooted, that even a native Hebrew speaker like me didn't get it
> until just now... But I think that if we want to be 100% accurate, then
> the head/tail names are more correct.
> Yuval
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at