Boost logo

Boost :

From: Emil Dotchevski (emildotchevski_at_[hidden])
Date: 2006-07-10 00:58:37


I am contemplating a few minor changes to the exception library and I wanted
to get some input before I implement them.

First, I think that the function template failed should be renamed. Somehow,
boost::failed doesn't feel right. Since English is not native to me, I
really need help with this one.

Second, I'm thinking of renaming wrap_string/get_string. Those names did
make sense in the implementation I've been using in my own code, because the
whole thing was in namespace except. Clearly, boost::get_string doesn't
suggest that it's part of the exception library. I'm thinking of renaming
them both to exception_string. So, stuffing a string at the time of the
throw would look like this:

throw failed<foo>() << exception_string<tag>("value");

To extract the string from an exception_info object, you'd do this:

exception_info & xi;
if( std::string const * s = exception_string<tag>(xi) )

Similarly, it makes sense to rename both wrap_errno/get_errno to

Thanks for everyone's input!


Boost list run by bdawes at, gregod at, cpdaniel at, john at