Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2006-07-10 09:28:16

Kevin Spinar wrote:

> Also, the clone_ptr library has been updated (
> ): the
> boost::*_pointer_cast functions have been implemented.


    template<class Y, class Alloc> clone_ptr(Y * p, Alloc); // Y must be

The template parameter name 'Alloc' implies a standard allocator. This is
pretty confusing; you should rename it to CloneAlloc if you really want to
use the 'CloneAllocator concept'. The alternative is to just take a standard
allocator. You might also want to not ignore the actual argument and make an
effort to support stateful allocators (although this is somewhat more
complicated, it is also considerably more useful.)

Boost list run by bdawes at, gregod at, cpdaniel at, john at