Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2006-07-11 12:50:37

Paul A Bristow wrote:
>> -----Original Message-----
>> From: boost-bounces_at_[hidden]
>> [mailto:boost-bounces_at_[hidden]] On Behalf Of Deane Yang
>> Sent: 11 July 2006 17:15
>> To: boost_at_[hidden]
>> Subject: Re: [boost] [math/staticstics/design] How best
>> tonamestatisticalfunctions?
>> > What about the Qs? (complements)
>> In other words, 1 - P. Right? One response is why do you
>> need to define
>> it, given how easy it is to get from the cumulative density
>> function?
>> If not, use a common name for it. Unfortunately, I don't have a good
>> suggestion.
> Perhaps not really needed? Is there an accuracy reason for both?

It depends how accurate you want to be: calculating 1-P incurs cancellation
error if P is very near 1, where as for most (all?) distributions we can
calculate Q directly without the subraction from unity.

>> Here's a first stab (I'm sure it can be improved):
>> class StudentsT
>> {

I think the "Boostified" name would be in all lower case: students_t or


Boost list run by bdawes at, gregod at, cpdaniel at, john at