Boost logo

Boost :

From: Howard Hinnant (howard.hinnant_at_[hidden])
Date: 2006-07-18 10:17:10

On Jul 18, 2006, at 12:29 AM, Kevin Spinar wrote:

> Also, I'm still unsure of a name; clone_ptr
> is more recognizable but clone_obj is more accurate of a name.

I have a strong opinion that this should be named clone_obj.

I think this work is interesting, and have been following it.
However at the end of the day, (imho) we still need a simple, basic,
clone_ptr, which has more in common with other smart pointers than
this work has. Let's keep the name clone_ptr available for *that*,
and name *this* work something else (clone_obj sounds good).


Boost list run by bdawes at, gregod at, cpdaniel at, john at