Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2006-07-24 13:48:57

"David Bergman" <David.Bergman_at_[hidden]> writes:

> I suggest that we call anything applicable via mpl::apply a "metafunctor."
> And have "metafunctoid" denote that category extended with #1 - ordinary
> metafunctions - above.

No strong objection

> It is a bit boring not to be able to use a common name for these constructs,
> especially when trying to tech others about metaprogramming techniques in
> C++. And I do not see such common names in the MPL documentation (or book.)

Yeah, we managed to write the whole book without such a name, which
suggests maybe it isn't really needed.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at