Boost logo

Boost :

From: Cromwell Enage (sponage_at_[hidden])
Date: 2006-07-30 10:17:18

--- Johan Råde wrote:
> "rank tree" is not a good name.
> It focuses too much on the implementation.

rank_tree is fine for the name of the class.

> What matters to the user is that it is a
> 1. sequential container with
> 2. O(log(n)) look-up and
> 3. O(log(n)) insertion

What's needed is a new Container concept that covers
these requirements.

> So what would be a good name?

I'm thinking 'Logarithmic Access Container', analogous
to std::vector fulfilling the requirements of a
'Random Access Container'.

                              Cromwell D. Enage

Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around

Boost list run by bdawes at, gregod at, cpdaniel at, john at