Boost logo

Boost :

From: Johan Nilsson (r.johan.nilsson_at_[hidden])
Date: 2006-08-23 04:47:21

Julio M. Merino Vidal wrote:
> On 8/17/06, Oleg Abrosimov <beholder_at_[hidden]> wrote:
>> Hello Julio,
>> First of all, I want to thank you and your mentor for the new great
>> library. I've started to read it's docs from top to bottom and I
>> have a few comments till now:


>> 5) the argument member function is non-intuitive. it is a noun but
>> should be a verb like add_argument. The name proposed is even more
>> verbose than current one, it leads to the next suggestion: use
>> 'operator<<' to append arguments to command line object.
> Agreed. I'd rather call it 'add'. And maybe also provide operator<<.
> Could the operator make things clearer?
> cl.add("foo").add("bar").add(4);
> cl << "foo" << "bar" << 4;

FWIW, +1 for "add_argument".

// Johan

Boost list run by bdawes at, gregod at, cpdaniel at, john at