Boost logo

Boost :

From: Andy Little (andy_at_[hidden])
Date: 2006-09-22 20:26:28

"Joel de Guzman" <joel_at_[hidden]> wrote in message
> Andy Little wrote:
>> "David Abrahams" <dave_at_[hidden]> wrote in message
>>> AFAICT the name ftag should be changed to something more descriptive
>>> and more certainly unique, e.g. boost_fusion_iterator_tag. Is there
>>> a reason it needs to be so short?
>> Why make such a trivial change to the interface post review? AFAICS now is
>> too
>> late, and will cause unnecessary pain to users.. like myself.
> Well, actually, it shouldn't be a part of the interface.
> Here, I'm used to calling it the f#%$tag :) It's not supposed
> to be for public consumption, and I intend to enforce that.
> Either way, it's not a good name (especially for minors. ;)
> and it must be changed.

And BTW its pretty public in the 'make your own iterator" part of the docs.

So far I have made 5 fusion style iterators. Next is the matrix minor iterator,
which extracts minors from a matrix, as a prelude to extracting cofactors.
Fusion::Views are wonderful things ....

Andy little

Boost list run by bdawes at, gregod at, cpdaniel at, john at