Boost logo

Boost :

From: Janek Kozicki (janek_listy_at_[hidden])
Date: 2006-09-27 15:09:26


what is planned longest time span, that boost::timer should cover without

I'm asking, becuase I was doing calculations that took approx 14 hours.
On amd32 boost::timer worked perfectly, but on amd64 the results
were obviously wrong.

Maybe there should be a test added to regression tests in this releasse
for boost::timer, that would invoke sleep(some_time), then test if
measured time is correct ? The some_time could be only 24hours.
That would make sure that timer at least works correctly for just one

Luckily I was measuring time by three means:

- boost::timer (worked only in 32bit),

- assembler (32bit) self written timer (worked only in 64bit) (*)

- zsh's time command used when executing the program (worked in 32bit AND 64bit !)

(*) because in 32bit the variable was too-short and there was overflow

BTW, I was comparing the performance between amd32 and amd64, if you
want, you can have a look at that:

OTOH: maybe that was already fixed? on that computer I have boost 1.33.1
(debian etch). If fixed, then I can verify this with new boost version.

Janek Kozicki                                                         |

Boost list run by bdawes at, gregod at, cpdaniel at, john at