Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2006-10-05 10:45:34

"" <noreply_at_[hidden]> writes:

> Bugs item #1571188, was opened at 2006-10-05 10:10
> Message generated for change (Tracker Item Submitted) made by Item Submitter
> You can respond by visiting:
> Initial Comment:
> the identifier none exists in two different headers.
> as "bool boost::none(InputIterator first, InputIterator
> last, Predicate p)" in detail/algorithm.hpp and as
> "none_t const boost::none = ((none_t)0)" in none.hpp

IMO, we've gotta stop sprinkling names into namespace boost. It just
isn't scalable.

Dave Abrahams
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at