Boost logo

Boost :

From: Jason Hise (0xchaos_at_[hidden])
Date: 2006-10-30 17:20:12

On 10/30/06, Michael Fawcett <michael.fawcett_at_[hidden]> wrote:
> How about ra_sequence?

Random access sequence sounds like the definition of vector more than
a new container type. Actually, I wonder if it is even valid to say
that this container supports random access... although it supports the
syntax for it, isn't random access defined as being constant time?

> > Perhaps it would be best to leave the ultimate decision up to the
> > library author, who came up with the idea and may want the privlege of
> > choosing a name for it. If he would prefer to leave the decision to
> > group concensus, we could put the name to a vote.
> It seemed like the author was asking for suggestions. I can't speak
> definitively for the others, but I don't think anyone was presuming to
> name the library for him.

I guess I felt guilty that I brought up the naming issue, even though
he subsequently mentioned he was looking for a better name, because it
derailed the topic to some degree. What I meant to say was that
focusing on reading through and commenting on his implementation is
probably a higher priority, and the name discussion should either be
happening parallel to that or it should be put on the back burner. My
apologies if the statement sounded accusatory.


Boost list run by bdawes at, gregod at, cpdaniel at, john at