Boost logo

Boost :

From: Jason Hise (0xchaos_at_[hidden])
Date: 2006-10-30 21:00:01

On 10/30/06, Martin Knoblauch Revuelta
> Back to the naming issue, and more important: another precedent of the
> idea in boost, "order-statistics trees" together with "ranked indices"
> are the names used in the "future work" section of multi_index
> documentation:

My opinion is still that os-tree is a name for the underlying data
structure, not the sequence interface itself. Rank may be a good
adjective for some sort of composite name though. Maybe 'rankseq', or
'ranklist'. I still like the simplicity of 'chain' though.


Boost list run by bdawes at, gregod at, cpdaniel at, john at