Boost logo

Boost :

From: Fernando Cacciola (fernando_cacciola_at_[hidden])
Date: 2006-11-01 17:16:11

Hi Ullrich,

> Consequently, the right term is pixel_value, and GIL is halfway right,
> because the associated typedef is already called pixel_value_type.

FWIW it is precisely that what prompted me to suggest renaming pixel<> to
That class does not neccesarily represent the "element of the picture" that
we call pixel.
In fact, for a planar image, the class "planar_ref" comes a lot closer to
that purpose, and in that context, the class pixel<> is used to capture a
deep-copy of that pixel's value.

> Calling the concept itself pixel_value would just be consequent,

Since a few people pointed put that the value of a pixel is not neccesarily
a color, I like this suggestion.

Now, off the pixel/color topic.
rom the Quicktime format disccusion: is it possible to supersample (rather
than subsample) an image? That is, to take two or more consequtive pixels in
a row and pretend is just one pixel? I ask because the lack of uniformity in
even/odd pixels in the v210 format could be elegantly solved this way (that
is if IIUC the problem).


Fernando Cacciola

Boost list run by bdawes at, gregod at, cpdaniel at, john at