Boost logo

Boost :

From: Martin Knoblauch Revuelta (mkrevuelta_at_[hidden])
Date: 2006-11-27 20:59:26

On 11/20/06, David Abrahams <dave_at_[hidden]> wrote:
> "Paul A Bristow" <pbristow_at_[hidden]> writes:

> > Do you also need a total newbie to report back when trying it out?

> Absolutely. I need several!

I tried to build Boost 1.33.1 and the example program with gcc 4.1.2
in kubuntu 6.10.

It worked! :-)

Well, I got some warnings and the final "Not all Boost libraries built

When I make again, I get:

./tools/build/jam_src/bin.linuxx86/bjam -sPYTHON_ROOT=/usr
Building Boost.Regex with the optional Unicode/ICU support disabled.
Please refer to the Boost.Regex documentation for more information
(and if you don't know what ICU is then you probably don't need it).
...found 10626 targets...
...updating 24 targets...
gcc-C++-action bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/bzip2.o

    set -e
    "g++" -c -Wall -ftemplate-depth-255 -g -O0 -fno-inline
-I"bin/boost/libs/iostreams/build" -I"/home/martin/boost_1_33_1" -I
"/home/martin/boost_1_33_1" -o
    "/usr/bin/objcopy" --set-section-flags .debug_str=contents,debug

...failed gcc-C++-action
gcc-C++-action bin/boost/libs/iostreams/build/libboost_iostreams.a/gcc/debug/zlib.o


I have no idea what this is all about, but I got to compile, link and
run the example so... :-)

I had a little problem with the libraries: I installed them in
/usr/local/lib (deafult location, isn't it?), but the system didn't
find them at runtime. I had to append /usr/local/lib to
/etc/, and then run ldconfig. I decided to do so after


Boost list run by bdawes at, gregod at, cpdaniel at, john at