Boost logo

Boost :

From: Yuval Ronen (ronen_yuval_at_[hidden])
Date: 2007-03-19 17:51:24

Peter Dimov wrote:
> Hello everyone,
> I'd like to start working on a Boost implementation of my threading proposal
> N2178:

Just some naming comments, if I may:

It seems to me the word "lock" is used with different meanings. For
example, there's a "rwlock" and the scoped wrappers for it are
"read_lock" and "write_lock". Very confusing, IMO. I think the word
"lock" should either be used for the synchronization classes, or for the
scoped wrappers, but not both.

The word "scoped" appears only for mutex's scoped_lock, although
read_lock and write_lock are also scoped. My opinion is that this word
should either be part of the names of all the scoped wrappers or none of
them, in a uniform manner.


Boost list run by bdawes at, gregod at, cpdaniel at, john at