Boost logo

Boost :

From: Matthias Schabel (boost_at_[hidden])
Date: 2007-03-29 15:14:51

> One more thought, instead of:
> q = quantity<SI::length,double>(r);
> what about a syntax like
> q.convert_from(r)
> to emphasize that this is performing a safe unit conversion, and to
> avoid having to repeat the type name?

We currently have a static member function that works like that :

q = quantity<SI::length,double>::from_value(r);

Maybe that's enough...


Boost list run by bdawes at, gregod at, cpdaniel at, john at