Boost logo

Boost :

From: brass goowy (brass_at_[hidden])
Date: 2007-04-03 18:12:08

>Thank you to Ion Gaztañaga for all the hard work >involved in creating a Boost library, to Olaf Krzikalla, >who wrote the first versions of this piece of work, >and to all the participants in the review. > >The list of issues to be addressed follows. Feel free >to comment if you detect some error or omission from >my part. I don't recall any mention of marshalling/serialization support in the reviews and the documentation table of contents doesn't mention it. >* Naming >- Change Destroyer to a more suitable name (e.g. Sink or > Disposer), rename member functions accordingly. >- Rename current() as iterator_to(). >- Rename [s]list_algorithms as circular_[s]list_algorithms. >- Drop the 'i' prefix from the names of containers. I disagree with this one. I think std and intrusive containers will often be used together. This decision will lead to longer names in those cases. I would support dropping the prefix if the resulting name wasn't the same as in the std. Why not get rid of all the vowels and call them lst? Brian Wood Ebenezer Enterprises

Boost list run by bdawes at, gregod at, cpdaniel at, john at