From: Andy (atompkins_at_[hidden])
Date: 2007-05-08 09:41:50
<Oliver.Kowalke_at_[hidden]> wrote in
> Hello Andy,
>> > Hello,
>> > Instead of
>> > bool is_null() const
>> > and
>> > static guid const& null()
>> > I would prefer
>> > bool is_nil() const
>> > and
>> > static guid const& nil().
>> I prefer null, but I can easily be swayed by this groups voice.
> It was only a suggestion - in the rfc 4122 for UUIDs
> (http://www.ietf.org/rfc/rfc4122.txt) nil is used instead of null.
> As I read in one of your responses that you would change the name from
> guid to uuid in order to be standard conform.
> Regards, Oliver
I didn't notice that. Neither is mentioned in
Unless there is opposition, 'bool guid::is_nil()' it is.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk