Boost logo

Boost :

From: Eric Niebler (eric_at_[hidden])
Date: 2007-05-13 13:19:05

Maurizio Vitale wrote:
> Eric Niebler <eric_at_[hidden]> writes:
>>>> For instance mpl has plus and proto has add (but unary_plus).
>>> Oh my. You're right, that's awful. I'll fix these.
>> I've changed the names of some types in proto to bring it in line with
>> conventions established in <functional> and Boost.MPL. This should
>> affect just about everybody currently using proto. In particular:
> I've just noticed you still have {left,right}_shift vs. shift_{left,right} of boost::mpl.

You're right. I'll change this, but probably not until after BoostCon.

Eric Niebler
Boost Consulting

Boost list run by bdawes at, gregod at, cpdaniel at, john at