Boost logo

Boost :

From: Hartmut Kaiser (hartmut.kaiser_at_[hidden])
Date: 2007-05-21 17:47:25


 
Eric Niebler wrote:

> I thought about that, and it's not unreasonable, either. It
> might cause less confusion. However, the different or_'s will
> often be used together, making qualification a requirement.
> Compare the following (assumes using namespace proto;):
>
> struct MyGrammar
> : control::or_<
> operators::or_<_,_>
> , operators::bitor_<_,_>
> >
> {};
>
> to
>
> struct MyGrammar
> : or_<
> logical_or<_,_>
> , bitwise_or<_,_>
> >
> {};

I don't mind having it the first way. Explicit is always better than
implicit. If that's too longish somebody could always use a using namespace
specification for whatever variant it may fit...

My main concern is name compatibility to mpl.

Regards Hartmut


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk