Boost logo

Boost :

From: Michael Marcin (mmarcin_at_[hidden])
Date: 2007-06-01 14:45:49

Daniel Frey wrote:
> For the name, noncopyable_base is too much typing for my taste, YMMV.
> Ideally, it would have been noncopyable<T> from the very beginning,
> but
> it's too late for that, so I think adding a simple _ is the least
> intrusive change. Anyway, it's a valid idea to use _base, let's see
> what others think.

If it has to be changed anyways I'd recommend uncopyable<T>.

As Scott Meyers says in Effect C++

"That class is named noncopyable. It's a fine class, I just find the name a
bit un-, er, nonnatural."

- Michael Marcin

Boost list run by bdawes at, gregod at, cpdaniel at, john at